Linux Lunacy!


Ad: Buy Girls Und Panzer Merch from Play Asia!

Maiku_Ando

-sama
Staff member
Leader Council
Since native Android vers get all the Microsoft subscription apps out of the way,
I take it via one of those emulators? I was considering trying MS stuff via Vivaldi. I actually noticed I hadn't mentioned that in the thread, but I am loving it, however I am getting ahead of myself... so let me show WHY...

Firefox_fun_Screenshot_20221002_154321.png

Right then.. place your bets on what you are looking at :)
This is Firefox, right after logging in. The lovely angel on the right is of course Maho-samma, which is my desktop wallpaper, the white logo thing in the middle is the kde plasma logo from the login greeter. Yes, Firefox is somehow managing to pull in old graphics and then crash.

I finally had enough of the BS and switched to Vivaldi, but while searching for an alternative I got so desperate I actually installed Edge on Linux. I need to be shot I know, but it was actually quite nice.

Hardware wise... I still need to pick up an ATI card. My Steam Deck has impressed me in regards to game compatibility and performance, so I'm really looking forward to getting my next video upgrade.
I note that GPU prices are still high, but there are rumours of a GPU price crash coming, so fingers crossed. I hear the RTX 4080 is not selling due to Nvidia's insane pricing, so plenty of stock it seems.

On a more random note, has anyone figured out how to fix the GTK3 file chooser crap so it properly puts buttons on bottom instead of in the title bar? I keep striking out when I search for it, it seems this is just how Gnome's engineers have decided to wage war on user experience.
Hold up, I'm still trying to get stuff to actually display in a sane order, like directories first -am looking at you Firefox- There is such a mess right now on the Linux desktop its driving me nuts, so many little stupid things. I think part of the problem is everyone seems to have given up on fixing anything and just saying praise weyland, it will fix all!.

I said this on IRC, but holy crap. The overkill. To think I'll be doing good to hardwire with regular ethernet next year, lol.
Yea but dam it is fun lol. I have a routerboard I'm messing with now, testing it to see if I can use that as a new router, BUT, I discovered its CPU is actually quite small, and then I discovered the CPU in my 16-port 10gig fibre switch is the same, meaning I could actually get my new fibre switch to do the routing as well as the 10gig switching. I've started naming the router interfaces of things with the speeds now, and the idea of seeing an entry in the traceroute to the ddl server with something like mahoro-xe-prod.fansub.tv would be pretty cool. The XE meaning 10gig Ethernet, yea yea I know the uplink further up isn't 10gig but it still looks cool lol.

Speaking of cool, it has now been confirmed that I can have a second multi-gigabit capable fibre internet line installed at my place via my current isp without needing any tunnelling, so I could actually split traffic over the two lines, using different backbones and have my isp automatically failover the routing if either goes down or load balance when they are both up. I just need to buy the line, and sadly I can't justify paying another £40 a month on it, despite my isp being like "sure you can join the trial!"

I am progressing on with the upgrade/replace my router/mahoro project, poor thing has been running for literally years without a reboot.
Bash:
root@mahoro:~# date
Thu Dec 22 07:06:47 GMT 2022
root@mahoro:~# uptime
 07:06:48 up 1371 days, 18:28,  1 user,  load average: 0.05, 0.08, 0.10
root@mahoro:~#
Shes still going..what a champ.
I have now built a new "legacy" services server called Mahoro-L185, some more details on it here, but basically it is Debian 10 and PHP 5.6 from Sury org which is maintaining a project to patch security updates, which is oddly part funded by Microsoft and another company. So I can run the old site code on a modern OS, it could in theory run the old FTV code too, it is on the list of weird stuff to try. But more fun happened there as the DB was a new Maria (10?) install and the old DB was like version 5 and MyISAM and on top had some charset issues because apparently the latin1 default was swedish at one point and now isn't or something and stupid old forum claims to support innodb but it actually just ignores the database created type and makes all the tables MyISAM anyway and then when you try to use unicode it breaks because it pushes the storage limit for that type or something because unicode needs more bits to handle the same length. So long very painful story short, I had to make yet another server running Ubuntu 14 just to run the old DB.

Now because its Ubuntu 14 I don't want that anywhere near to being accessible so I created a new DB subnet which is behind the web servers so only they can access it, and then fire-walled as well so even if the web server gets compromised it still limits what can get in. I then had to modify the new DDL server to point to the split DBs, one on the debian 10 box and one on the Ubuntu 14, which of course meant I had to add that onto the new DB network. But then I need the main site to talk to the DB for the DDLs so then I had to modify the VPN server which is providing a link between the main FTV server and the prod network here, and again alter the networking. I also discovered the DNS was all wrong for the prod network and the servers so spent like an hour fixing all of the forward and reverse DNS for the network. This is what happens when you decide to post a spam comment on a popular Youtube video to advertise FTV and then realise the site is in such a mess it can't handle any new DDLs if someone tried, and therefore start a "10 minute fix" which took all night.
 
Last edited:

Maiku_Ando

-sama
Staff member
Leader Council
I finally got fed up with the little glitches I was getting in Debian 10, so I decided to try Arch btw. I decided to record some notes about the experience and as will become apparent, the glitches I encountered.

Debian 10
PackageIssueResolutionComment?
FirefoxGraphical glitches, crash on login restore.Disable KDE session restore? (not tested) or use Vivaldi.Much better browser, so OK.
DolphinFile op progress in background, no notifications.Turn off Notifications on every monitor, add window rules.Stupid, but fixable so OK.
DolphinNo thumbnails for videos.none, not supported.Annoyance.
VivaldiRight click menu randomly stops working.Minimize and restore.Annoyance.

Debian 11 (initial pre-arch testing, need to revisit).
PackageIssueResolutionComment?
KRDCRandom disconnects.None, use Remmina ? (not tested).freerdp Dev refuses to fix.
DolphinFile op progress in background, no notifications.Debian 10 fix doesn't work. Nothing found.Unacceptable, stupid (deal breaker).
Vivaldi, firefox, MPV, Remminanot yet tested.See notes below.

Arch (Manjaro) Btw.
PackageIssueResolutionComment?
KRDCRandom disconnects.None, use Remmina.freerdp Dev refuses to fix.
RemminaGraphical glitches, odd crash on start up.None.Annoyance.
VivaldiRight click menu doesn't use theme.Change theme type to GTK in chrome settings.OK
MPVLoop dosn't work on single L press.Make .config/mpv/mpv.conf with loop setting.OK
OS in generalSome text randomly in Japanese when language pack installed.Nothing found yet.ii..i don't mind if its you ss..sempai.
Amusing, so its OK for now, also not needed anyway.

The reason for trying Arch btw was due to having issues when I had previously tried Debian 11 and Debian 12 is not likely to be released until mid 2023. The results for Debian 11 above are from the previous testing, and I have not had a chance to try again after what I have learnt from the Arch testing. A note on Arch btw, Arch btw on its own looks to be a real pita to install as it has no installer and is all manual building, I guess they have their reasons but it feels lazy to me, and I was too lazy to bother with it, therefore I used Manjaro which has an installer.

I had intended to make this post yesterday but I managed to break my Manjaro btw install on my test PC in true Linus (Sebastian) style. I misunderstood the driver installer interface thinking I needed to install the video-linux, video-modesetting and video-vesa drivers. I think Linus even commented on this interface but I had forgotten it at the time.

Screenshot_20230107_230703.png

Installing the 3 open source drivers conflicts with the Nvidia driver, and with no warning and a reboot later I am greeted with a blinking cursor and no desktop. I tried removing the packages via pacman but that did not work. I ended up leaving it until the next day and after 4 unsuccessful usb key boots (because my old i7 4770k seems to be going a bit senile in its old age) I was able to consult the Manjaro Wiki and copied down some of the command line hardware manager examples. I rebooted into the broken install, and managed to remove all 3 of the opensource drivers that were conflicting and got back into the GUI, which I am now using to make this post, btw.

Next plan is to maybe do some more Manjaro-btw testing and also give Debian 11 another try now I have some ideas on a work a round or 4. I am also considering giving Debian 12 a try, even though it is in unstable right now just to see what its looking like. I might consider Fedora too.
 
Last edited:
Playasia - Play-Asia.com: Online Shopping for Digital Codes, Video Games, Toys, Music, Electronics & more
Top