Jump to content


Photo

Help with subtitle formatting during playback.


  • Please log in to reply
3 replies to this topic

#1 Prideless

Prideless

    -san

  • Sempais
  • PipPipPip
  • 294 posts
  • Location:Lancaster, California
  • Interests:DUR! DUR! Anime and Manga obviously aside from that bowling, movies, racing and tennis. >=D

Posted 26 October 2011 - 03:52 AM

I am using WMPC I have had this issue for like a year just never really got around to fixing it.

I am having subtitle problems mainly with "Title subtitles" (not the subtitles that appear bottom center. Like subtitles that the episode title or various signs in anime that have been subbed. They always appear 80% off screen to the right. Other than those subtitles watching the anime is just fine bottom center as usual. Tried mingling with the settings none seem to fixing it.

Would be great if someone knew exactly how I can fix this issue.

Thanks.
Click the link below to my Tutorial Thread in how to Enhance your Anime Experience with your Graphics Card.
http://boards.fansub...t=0#entry280724

user posted image Click Sig Image to Youtube Page.
user posted image

#2 truth2belief

truth2belief

    -dono

  • MATV Crew
  • PipPipPipPip
  • 600 posts
  • Gender:Male

Posted 29 October 2011 - 07:48 PM

I can't be of complete help unless I know the specific anime, group, and version that you are trying to play. Judging from what you explained, your video is likely overriding subtitle placement.

Normal subtitles on the bottom aren't typeset to be in a specific place and are placed in the 8 position (placement based off the center-middle of the subtitle) and if normally used with should automatically place itself at the bottom of the screen. Typeset subtitles, found mainly for background text such as signs and letters on cell phones, TVs, etc. are positioned manually and thus are positioned mostly in different manners. Many like to use the 7 (placement based off the top-left of the subtitle) or 1 (placement based off the bottom-left of the subtitle). Typesetters like to use these placements cause they are easy to position text. So when you have a placement overwrite in MPC, it will put the subtitles in the bottom of the screen in the center based off the placement point. Thus if the placement point is 1 or 7 which is on the left side of the text, then that point will be at the center and the text to the right.

You can turn off subtitle placement override by going to view -> options -> subtitles and within this options screen, you should un-check override placement.

If this doesn't work, then make sure you have the latest version of MPC preferably by CCCP. Generally, very complex typeset work such as moving fancy words (such as when a character is scrolling through their phone text message) are hardsubbed (unless the group has a policy against the modifying the RAW and give you the subtitle file so that you have the option of watching the RAW video) so you may see problems in certain places but not others. So you will find this problem in a lot of MKV files since mkv generally is not hardsubbed (at least not the bulk. karaoke OP/ED are often hardsubbed). mp4 and AVI files are 99% of the time hardsubbed so if you don't want any issues and don't want to solve the problem, that's the way to go.

Again, I'm not sure what video you have and so I can't say for sure.

Original Artwork by JinK
Too lazy to go past "D"

#3 Prideless

Prideless

    -san

  • Sempais
  • PipPipPip
  • 294 posts
  • Location:Lancaster, California
  • Interests:DUR! DUR! Anime and Manga obviously aside from that bowling, movies, racing and tennis. >=D

Posted 30 October 2011 - 02:05 AM

wow thanks for the information and the help its much appreciated.

Ill give you some examples hopefully it will help. Also the Override subtitle placement was already unchecked. Is position subtitles relative to video frame? should be checked or unchecked?
Click the link below to my Tutorial Thread in how to Enhance your Anime Experience with your Graphics Card.
http://boards.fansub...t=0#entry280724

user posted image Click Sig Image to Youtube Page.
user posted image

#4 truth2belief

truth2belief

    -dono

  • MATV Crew
  • PipPipPipPip
  • 600 posts
  • Gender:Male

Posted 31 October 2011 - 03:55 AM

I'm somewhat stumped on this as you don't have a problem caused from your options. I don't see that option in my MPC. Try turning it on and off and play the video. I would assume it should be off since subtitles are usually placed by pixel location x & y rather than percentage. I'm using MPC-HC. Windows Media Player Classic, the version made by Microsoft, can be seen as inferior to the Media Player Classic Home Cinema version, which is a modified MPC. MPC-HC can be found when you get and install the Core Community Codec Pack.

Have you tried using other players? VLC? WinAmp? While I don't recommend using other players with as much vigor as MPC-HC, it's always nice to have VLC as a backup since VLC is a standalone player and doesn't require codecs. The people behind VLC made x264, afterall... The new VLC can do typeset videos but the VLC from a couple years ago couldn't and put all subtitles on the bottom and you had problems watching subtitles layed over more subtitles. So make sure you have the latest version player, for any video player that you have.

You can msg me with a DDL link if you have one and I can see if I have the same problem. I don't do torrent. If the problem is only with certain videos from certain people, than I can see it being a problem with the subtitle file embedded within the video. But if it's from a random lot of videos, than it's on your side. If you have more than one, can you list them for me including the file type and full file name (ex. [group name] Anime - 01 [h264 AAC] [CRC].mkv)?

Also, when you play the video using MPC or MPC-HC, you might see on the bottom right in your system tray 2 to 4 symbols pop up when you play a video. You may not see it if you don't have it enabled in the options, but if you do, you may see an icon depicting a green arrow curving and pointing to the top-left corner. This means you have VobSub which is currently probably the most used subtitle viewer. You want to check your VobSub settings if you have it. If you play your video with MPC, you should right-click on the video screen and go to filters -> DirectVobSub -> Properties. Under the Main Tab, make sure override placement is off here, too. Under the General Tab, make sure Vertical Padding is at Original Height.

Original Artwork by JinK
Too lazy to go past "D"




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users