Jump to content


Photo

Windows 7 + Subtitles


  • This topic is locked This topic is locked
4 replies to this topic

#1 dchaosblade

dchaosblade

    - Lord of Chaos

  • Retired
  • PipPipPipPipPip
  • 2992 posts
  • Location:10m below the Southern ice cap of Mars
  • Interests:Too many to list, but to get a start on it: quotes, reading, writing, anime, games, computers, &c.

Posted 16 May 2009 - 10:38 PM

Okay, so I'm currently running Windows 7 RC on my comp, and trying to watch some anime. When I play anime in ZoomPlayer, it forces Win 7 to turn off the aero theme (rather annoying) until I close ZoomPlayer, so I've been trying to use Media Player Classic (MPC) instead.
The thing is, MPC doesn't seem to want to display the subtitles. I've tried resetting the settings on CCCP to no avail. I've also tried changing the subtitle track (a couple of my animes have several tracks to choose from) but it doesn't make a difference. The subtitles show up fine in ZoomPlayer and switch without a problem.

It's a clean install of the OS and the CCCP (no other codecs were installed before or after CCCP). The files in question are all .mkv with soft-subs. .avi (hard-subbed) files have no problem. I've tried the usual steps (changing subtitle track, resetting CCCP options, reinstalling CCCP) so I'm not sure how to fix this one. Is MPC not fully compatible in Windows 7 RC?
Don't forget, the edit and search buttons are your friend!
user posted image

#2 Kid-Wolf

Kid-Wolf

    ~ Random Touhou link finder ~

  • MATV Crew
  • PipPipPipPipPip
  • 9125 posts
  • Gender:Male
  • Location:At the Board of Fantasy and Reality
  • Interests:Anime, Touhou, games (be they PC, console, or even traditional biased), Touhou, Meidos, Visual Novels, Touhou, oh and did I mention Touhou lol

Posted 16 May 2009 - 11:36 PM

It think the guys at the CCCP group are probably going to work on that since Windows 7 is pretty much a bare bones Vista OS system. Although the setup might be a bit different. The reason for that is a few sub groups have coded thier .mkvs with a beta version of subs that should work along with the regular subs.

- Miko Miko Mode Oni Version

#3 langes01x

langes01x

    -dono

  • Sempais
  • PipPipPipPip
  • 940 posts
  • Location:Calgary, Alberta - Canada
  • Interests:Besides anime and the occasional manga I like fantasy and sci-fi books, computer games (particularly RPG and RTS) and programming.

Posted 17 May 2009 - 12:09 AM

I've used Windows 7 and met this problem as well and the guys on the CCCP forum have a workaround that works. Make sure you close MPC and reopen it before testing to see if it works.

http://www.cccp-proj...g23025#msg23025

Basically it's a problem with VSFilter.

For redundancy I'll post the workaround here as well:
QUOTE
1. View | Options
2. Go to External Filters
3. Hit Add Filter...
4. Choose DirectVobSub (auto-loading version)
5. Where it says Prefer/Block/Set merit:, select Prefer


QUOTE (dchaosblade @ May 16 2009, 03:38 PM)
The files in question are all .mkv with soft-subs.  .avi (hard-subbed) files have no problem.

Of course the avi work correctly as the subtitles are in the video. You can't turn them off even if you want to.

#4 dchaosblade

dchaosblade

    - Lord of Chaos

  • Retired
  • PipPipPipPipPip
  • 2992 posts
  • Location:10m below the Southern ice cap of Mars
  • Interests:Too many to list, but to get a start on it: quotes, reading, writing, anime, games, computers, &c.

Posted 17 May 2009 - 12:24 AM

Thanks, I'll test that fix now.
I only stated the comment about avi hard subbed to prevent someone who doesn't know what they're talking about asking stupid questions or suggesting stupid solutions - which for some reason tends to happen with me a lot when I ask for assistance on things
(for example, refer to my tut request here - to which I got the response of looking in the animation palette which I had already said didn't have any frames except the first one)


Edit: That fix seems to have done the trick! Thank you very much langes01x! Glad I wasn't the only one with the problem xD
Don't forget, the edit and search buttons are your friend!
user posted image

#5 langes01x

langes01x

    -dono

  • Sempais
  • PipPipPipPip
  • 940 posts
  • Location:Calgary, Alberta - Canada
  • Interests:Besides anime and the occasional manga I like fantasy and sci-fi books, computer games (particularly RPG and RTS) and programming.

Posted 17 May 2009 - 03:15 AM

QUOTE (dchaosblade @ May 16 2009, 05:24 PM)
Thanks, I'll test that fix now.
I only stated the comment about avi hard subbed to prevent someone who doesn't know what they're talking about asking stupid questions or suggesting stupid solutions - which for some reason tends to happen with me a lot when I ask for assistance on things
(for example, refer to my tut request here - to which I got the response of looking in the animation palette which I had already said didn't have any frames except the first one)


Edit: That fix seems to have done the trick! Thank you very much langes01x! Glad I wasn't the only one with the problem xD

I was actually following that thread at one point but since I have little experience with gif creation I couldn't really help.

No problem. I ran into the same thing and did a little searching to try and fix it and came across the solution. Glad I could be of assistance.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users